Distant Horizons Mod For Minecraft 1.19+

Published Mar 5, 2022
Minecr4ftHub
  • 17,521
  • 21
Download Mod
How to install Minecraft Mods
Share Mod
Tell your friends about this mod!
6 Comments
6 Comments
Showing 1-6 of 6, newest first
Type some more! 10 / 10
KenjirouMymoto
KenjirouMymoto 6 months ago
You labelled the version wrong. The linked mod is not compatible with 1.18.2 yet, only 1.18.1.
FelbYouTube
FelbYouTube in reply to Minecr4ftHub 5 months ago
It does not yet work for 1.18.2. The creator will be releasing the updated version soon but for now it is incompatible.
DanielCarpusor
DanielCarpusor in reply to Minecr4ftHub 5 months ago
It doesn't work... at least on my pc, it requires a compatible version of distant-horizon with minecraft fabric 1.18.2. Does it work on your pc? on 1.18,2? If so please reply :).